إصلاح الخطأ: يبدو أن تثبيت PHP الخاص بك يفتقد ملحق MySQL المطلوب من WordPress

"يبدو أن تثبيت PHP الخاص بك يفتقد ملحق MySQL المطلوب من WordPress"هو خطأ واجهه العديد من أصحاب المدونات ومواقع الويب وورد.
هذا ليس مدعاة للقلق. عدم وجود امتداد MySQL من PHP هو نموذجي لأنظمة التشغيل المثبتة من الصفر أو VPS أو الخوادم المخصصة ، حيث لم تكن ملحقات PHP جزءًا من حزمة التثبيت. هذه المشكلة موجودة على كليهما أوبونتو وعلى CentOS. في هذا السيناريو ، يتم حل المشكلة ببساطة شديدة من خلال تحديث PHP وتثبيت الوحدة "فب-ماي".
قم بتحديث PHP وتثبيت امتداد MySQL على Ubuntu

apt-get update
apt-get install php-mysql

قم بتحديث PHP وتثبيت امتداد MySQL على CentOS

yum update
yum install php70w-mysql

بعد هذه الخطوة ، إعادة تشغيل خدمة Apache أو NGINX.

واجهت أيضًا السيناريو حيث على الرغم من وجود امتداد MySQL في PHP ، عرضت مدونة تم إنشاؤها على WordPress الخطأ "يبدو أن تثبيت PHP الخاص بك يفتقد ملحق MySQL المطلوب بواسطة WordPress". في معظم الأحيان ، يحدث الخطأ عند تثبيت WordPress. هذه المرة ، ومع ذلك ، ظهر في مدونة كانت نشطة لعدة سنوات.
في هذه الحالة ، وجدت أن المشكلة ليست في وحدات PHP ، ولكن الإصدار القديم جدًا من WordPress ، والذي لم يعد متوافقًا مع PHP 7.4.4RC1. أدت ترقية WordPress بسيطة إلى أحدث إصدار إلى حل الخطأ.

إصلاح الخطأ: يبدو أن تثبيت PHP الخاص بك يفتقد ملحق MySQL المطلوب من WordPress

عن المؤلف

تسلل

شغوفًا بكل ما يعنيه الأداة وتكنولوجيا المعلومات ، يسرني أن أكتب على stealthsettings.com من 2006 وأحب اكتشاف أشياء جديدة حول أجهزة الكمبيوتر وأجهزة MacOS وأنظمة تشغيل Linux ، Windowsو iOS و Android.

اترك تعليق